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From SONAR to REAPER

Introduction and Preamble

This booklet has been produced as an aid to experienced users of SONAR who are trying out REAPER, or who have already decided either to make the switch or to add REAPER to
their software collection.

It is an introductory guide, no more, no less. Each chapter consists of a table or a number of tables, devoted to one main aspect of using a DAW. Within each table you will find a
number of key tasks identified, together with a summary of how that task is approached in SONAR and how the same (or most closely equivalent) task is approached in REAPER.
The versions used are SONAR 8.53 and REAPER 3.65 with SWS Extensions 1.72. The SWS Extensions can be downloaded from http://www.standingwaterstudios.com

The layout has been designed so as to make it easy for you to print any page you wish as a summary information card. You will find more expansive and comprehensive
explanations in the REAPER columns of the tables than the SONAR ones. That is simply because I have assumed that as an experienced SONAR user you are already familiar with
how SONAR handles the various tasks. That information is provided as a reference point only, not to teach you how to use SONAR.

This document is far from being 100% comprehensive, nor is it intended to be, nor (probably) could it ever be. Keep in mind that there are some tasks that can be achieved in
SONAR but not in REAPER and vice versa. I have had to take some fairly arbitrary decisions about how this documentation approaches these at times, including what to include
and what to miss out. I didn't want to end up with another 400+ page manual! Its aim is to help you adjust to REAPER's way of working, not to teach you everything you could,
possibly want to know about REAPER. Be prepared in most cases to consult the REAPER User Guide and the SWS Extension Guide for more information on most topics.

Finally, to state the obvious, SONAR isn't REAPER and REAPER isn't SONAR. I've considered questions like whether it would be a good idea to create pseudo-SONAR menus that
you can use with REAPER, or pseudo-SONAR keymaps. After consulting with other ex-SONAR users I have decided against doing this. Apart from the extraordinary amount of time
this would take, there are more philosophical reasons. These are:

® The two programs operate in many cases quite differently and according to different design paradigms. Trying to “Sonarize” the REAPER menu would be at best a fudge.
Some commands would need to be included which are not strictly equivalent, others would be dropped off the menu all together.

@ Changing REAPER's keyboard shortcuts to more closely align with SONAR's key bindings would mean re-allocating keys currently assigned some other function (and often
an important function) in REAPER. In some of these cases, SONAR has no equivalent command.

@ In the end, the only way you will ever successfully be able to learn and use REAPER is ... to use it as REAPER, not as a sort of quasi-SONAR (or anything else). This might
make the learning curve a little steeper at first, but in the longer term this should save you time and deliver you benefits.

This represents a first attempt at producing this document. If you find any significant errors or omissions,or would like to suggest improvements, please PM nicholas on the
REAPER forum.

Finally, here's one more point to consider ...

One criticism sometimes leveled at REAPER (often by people who have never made any serious attempt to learn or use the program) is that it is “complicated” or “difficult” to use
because of its many hundreds of extra actions, many of which lie hidden below the surface. In my opinion, nothing could be further from the truth. REAPER's standard interface
contains all of the commands, functions and features needed to run it as a standard DAW. For the most part, the extra actions are there to help you if you want to tailor the
program to work more precisely in line with your own needs (for example, to improve your productivity and workflow). You don't need to do this if you don't wish to!
Enjoy!

— Geoffrey Francis, August 2010
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From SONAR to REAPER

1. Fundamental Design Differences

On the surface, SONAR and REAPER look quite similar. They are both Digital Audio Workstations. Both allow you to record audio and MIDI items. Both provide you with facilities for editing
these items. Both offer a number of useful features (such as VST plug-ins and automation envelopes) to help you to bring your projects to a final mix. And so on ....

That's on the surface. Once you start looking below the surface you will discover four very important things:

® There are some tasks common to both SONAR and REAPER which are accomplished in a similar fashion in both programs. However, these tasks are relatively few in number and
relatively basic. They include such standard Windows activities as saving files, opening files, closing files, deleting clips and items.

® There are some features which are common to both SONAR and REAPER but which are accomplished by different means in the two programs. For example, the default methods of
zooming in and out of, and navigating thru, a project are significantly different in both programs.

® There are some features which though broadly comparable in SONAR and REAPER vary significantly in their implementation and their functionality. For example, SONAR's Audio
Snap and REAPER's Dynamic Splitting both exist to serve similar purposes. Both, however, work differently from each other, and most users would consider SONAR's Audio Snap to
be more fully featured. Likewise, both programs make automation available to you, thru the use of envelopes and (in the case of REAPER) parameter modulation. Most people
who have used both programs for automation would say that REAPER is superior in this regard.

® Both programs possess features that the other simply does not have. For example, REAPER possesses no feature that is remotely comparable to SONAR's Staff and Lyrics Views.
On the other hand, REAPER does include channel splitting and includes a Routing Matrix View for which SONAR has no equivalent.

You will find the transition from SONAR to REAPER easier if from the outset you develop at least a general sense of the differences in the design paradigms of the two different programs.
The table below aims to explain some of the most important differences. It comes with the usual disclaimer that its statements are generalizations and perhaps at times over-simplifications.
Nevertheless, it should help to get you thinking along the right track.

SONAR REAPER

® Audio and MIDI items are called “clips”. In this document I'll use the REAPER term ® Audio and MIDI items are called “"media items”.

media items" when referring to SONAR dlips... ® Makes extensive use of Main Level Menus. These can be customized.

® Makes extensive use of Main Level Menus. These can be customized. Default toolbar is minimal. By default, REAPER makes little use of tools, but users

® Includes a large number general and specialist of toolbars, makes extensive use of can customize the main toolbar. You can also create your own tools and your own
tools. User can create custom toolbars. custom toolbars.

® Makes some use of right-click context menus. ® Makes extensive use of right-click context menus.

® Limited keybinding capability. ® Almost unlimited keybinding capability.

® No extra actions other than what appears on menus. No user macros. ® Literally hundreds of extra actions that can be combined with each other and with

® Some scripting capability thru CAL. REAPER commands into user-defined macros.

® Limited ability to customize program settings and options. Supports scripting using Python and/or Pearl.

Very many aspects of program behavior can be customized.

Some of these issues will be discussed further in the section Customization..
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2. Setting Up and Getting Started

Section Overview

Any DAW requires a certain amount of time to set up. These tasks include, for example, selecting your audio drivers and specifying the location of your VST plug-ins. In addition, you will
find that REAPER has many more pages of preferences settings — and many more options within those pages — than does SONAR. Don't be intimidated by this. Part of the REAPER design
philosophy is that wherever possible individual users should be able to customize program behavior if they wish to suit the way they want it to work. We'll get to many of these later, but for
the most part you'll most probably find that you can work perfectly well just leaving many preferences options at their default settings.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

The Install Process

Run the setup file, either downloaded or
from DVD

Download the latest version from http://www.cockos.com/reaper/downloads.php (updates with bug
fixes, performance enhancements and new features are usually released every two weeks or so).

You'll notice straightaway that REAPER installs quickly (a couple of minutes at most) and leaves a small
footprint.

Most of the elements listed in the Choose Components screen are self-explanatory. Check the Additional
Functionality options for such features as x64 VST Bridging, Control Surface Support, CD
Ripping/Burning, and Rewire. By default, most of these options are enabled.

You should also install ReaRoute ASIO drivers if you want to run REAPER linked to another program such
as SONAR.

Setting up Audio

Options - Audio

Options - Preferences - Audio
Options - Preferences =» Audio - Device (or click once on right end of main menu bar)
Note the following:

REAPER's Solo in Front is equivalent to SONAR's Dim Solo

REAPER's Channel Name Aliasing is similar to SONAR's Friendly Names

REAPER prefers ASIO drivers.

Setting up MIDI

Options » MIDI Devices

Options - Preferences - Audio » MIDI Devices
Double-click on any input or output device to configure settings.

Installing to a Flash or Thumb
Drive

SONAR does not support this feature.

From the Windows start menu, chose All Programs - REAPER - Install REAPER to USB Key or
Removable Media.
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Task/Activity In SONAR you did this ... In REAPER you do this ...
Setting up Control Devices Options - Controllers/Surfaces Use Options - Preferences - Control Surfaces for any device operating in any of these modes:
Behringer BCF2000 HUI Novation Automap
Frontier Alphatrack Mackie Control Extender Presonus Faderport
Frontier Tranzport Mackie Control Universal YAMAHA 01X

For BCR2000 users, please note that a plug-in has been developed by REAPER forum member ajaym
that allows you to install the BCR2000 as a control surface. See REAPER web site.

For other devices , use Options » MIDI Devices. Configure device to Input (Control Only) and output

disabled.
System Info and File Locations |SONAR stores much of its system REAPER does not use the Windows Registry. Most system information (FX Chains, Color Themes, Key
information in the Windows Registry. Maps, Menu Sets, 1S Effects etc) are stored in the App Data directory, accessed from REAPER's Options

You can use Options - Global » Folders to - Show REAPER Resource Path ... command.

specify the locations pf various file types. Native ReaPlugs (ReaEQ, ReaComp, etc.) are stored within the REAPER program directory.

Global default location for media files is specified under Options - Preferences ->Audio - Recording.
This can be overwritten for any project when saving the project file by selecting the Create Subdirectory
and Move All Media Items to Project Directory options. You can also set this in the File - Project Settings
dialog box.

Setting up VST and DX Plug-ins | Options - Global -» VST Plug-ins Options » Preferences - Plug-ins - VST
Options - Preferences - Plug-ins - Rewire/DX

Some DX plug-ins may not be automatically be recognized by REAPER. If this is the case, go to your
\Application Data\REAPER folder and edit the text file reaper-dxplugins.ini. You will need to change the
line Load=0 to Load=1 for those plug-ns that have not been recognized.

Keyboard Shortcuts, Tips and Techniques:

File - Project Settings Alt + Enter

Options - Preferences Ctrl + P

Navigate Preferences pages either with mouse or keyboard (press first letter off page name (e.g. type C to jump to Control Surfaces page). Wisuslization Create new proj

Use Find text box (bottom left corner of Preferences window) to search — see image on right. EGF;T?EEWS @
wierhal ILors W

Find )
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3. Recording Essentials

Section Overview

For the most part SONAR and REAPER handle creating tracks and recording in ways that are quite similar. The biggest and most obvious differences can be found in how the two products
handle MIDI recording. SONAR uses different track types for audio and MIDI, whereas REAPER uses one common track type for both audio and MIDI. In fact, with REAPER you can record
both audio and MIDI items on the same track if you wish. REAPER's basic track controls do not by default include the many controls that are included in SONAR's MIDI tracks. You can add
these via the command Show Track MIDI Controls in the main Track menu or the track context menu. Another major difference is that REAPER does not include a separate Synth Rack View.
REAPER does, however, include the following features:

¢ A Virtual Keyboard that you can use for MIDI input. Using either your mouse or your PC keyboard.

¢ It allows you to use as many different synths (and/or different instances of the same synth) as you wish within a single track, either in serial or in parallel.

¢ You can play back MIDI events from different channels thru different synths within a single track.

These features go beyond the scope of this “quick start” guide: for more information, consult the REAPER User Guide and/or REAPER Power!

Task/Activity In SONAR you did this ... In REAPER you do this ...
Create Audio Track(s) Insert » Audio Track Track - Insert New Track or Insert -» Track
Insert » Track from Track Template Track = Insert Track from Template or Insert » Track from Template
Insert » Multiple Tracks Insert - Multiple Tracks
Create MIDI Tracks(s) Insert » MIDI Track Track - Insert New Track then Track -» Show Track MIDI Controls
Insert » Track from Track Template Track = Insert Track from Template or Insert - Track from Template
Insert » Soft Synths Insert - Virtual Instrument on New Track
Arm/Disarm Audio Track For Use the track's Record On/Off toggle button. | Use the Record Arm/Disarm Toggle button in the track control panel. Default setting is to record
Recording track input.
Select Option to Record Track Not available. Right click on track Record Arm button, follow menu to Record: Output, then select your
Output (rather than input) preference from sub-menu..
Assign Track Inputs Use Inputs drop down list in track controls. Right click on track Record Arm button, follow menu to Mono Input, Stereo Input, or MIDI
input.
Assign Track Outputs Use Outputs drop down list in track controls. | Click on track I/O button to open the track's routing window. By default, output of all top level
By default, all audio track output automatically |tracks goes directly to the Master. Output of all child tracks (contained within folders) goes to
goes to the Master. the folder and from there to the Master.




Task/Activity

In SONAR you did this ...

From SONAR to REAPER

In REAPER you do this ...

Enable/Disable Input Monitor

Use the track's Input Echo button.

Use the track's Record Monitoring button, or right click on Record Arm button, follow menu to
either Monitor Input or Monitor Input (Tape Auto Style). Optionally, you may also enable
Monitor Track Media When Recording.

Input Quantize(MIDI)

Tracks - Input Quantize

Right click on track Record Arm button, then choose Track Recording Settings.

Select Record Mode Normal

Transport - Record Options then make sure
Auto Punch is not enabled.

Options - Record Mode: Normal

Select Record Mode Autopunch

Transport - Record Options then enable Auto
Punch.

Options - Record Mode Time Selection Autopunch or
Options - Record Mode Autopunch Selected Items

Enable/Disable Multiple Takes

Transport - Record Options then select Sound
on Sound or Overwrite.

REAPER's default behavior is similar to SONAR's Sound on Sound mode. Ctrl +L toggles display
of multiple takes in lanes. To use its equivalent of Overwrite mode, choose (from the Options
menu) Trim Existing Items Behind New Recording. REAPER also supports Free Item Positioning
Mode (on track context menu).

Show/Hide Virtual MIDI Keyboard

SONAR does not support this feature.

View - Virtual MIDI Keyboard.

Show/Use Metronome

Options » Project » Metronome

Options - Metronome and Pre-Roll Settings, or
Insert - Click Source (on selected existing empty track)

Start Recording

Transport - Record or use Transport Bar

Click Record button on Transport Bar.

Stop Recording

Transport - Stop or use Transport Bar.

Click Stop button on Transport Bar.

Other Transport Bar Functions

Core functions (Play, Stop, Pause, etc.) are similar. See SONAR and REAPER documentation for other features and differences.

Keyboard Shortcuts, Tips and Techniques:

Insert » New Track Ctrl + T
Options = Preferences Ctrl + P
Start Recording Ctrl + R
Stop Recording Spacebar

Show Multiple Takes in Lanes (toggle)

View - Big Clock (toggle)
View - Docker (toggle)

See also Options = Preferences - Audio - Recording for various options and settings.

Ctrl + L [1] “ocal Lead ﬂ w w f u .
Alt +C ar) $ _LL— 0.00dB center
Alt + D @S@

Record Monitoring: QM
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4. Tracks and Track Management Essentials

Section Overview

In many respects, REAPER's and SONAR's track management features are quite similar, and are available in the Arrange (Track) view and Mixer (Console) view . However, there are some
important differences, as explained in the table below. Not every option or feature is listed, only the most common ones. One key area of difference is in routing. REAPER makes no pre-
distinction between tracks and busses. Any track can be used as a bus and any bus can be a track.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Input Trim for Track or Bus

Use trim fader in the track panel.

No real input trim. Use Volume (Pre FX) envelope or a JS Volume plug-in in FX chain.

Adjust Volume

Click and drag track volume fader.

Click and drag volume fader. Use Ctrl key for fine tuning adjustments or Scroll mousewheel
over volume fader (this can be disabled in Preferences, Editing Behavior, Mouse) or Right
click over volume fader and enter a value.

Adjust Pan Click and drag track pan fader. Click and drag pan fader. Use Ctrl key for fine tuning adjustments or Scroll mousewheel over
pan fader (this can be disabled in Preferences, Editing Behavior, Mouse) or Right click over
pan fader to over-write default pan law.

Mute Track (toggle) Click on track mute button. Click on track mute button, or right click for various mute options.

Solo Track (toggle)

Click on track solo button.

Click on track solo button, or right click for various solo options.

Solo in Front

Use Dim Solo button.

Options = Solo in Front. Use Audio page of Options - Preferences to configure.

Freeze/Unfreeze Track

Click on Freeze button.

REAPER does not fully support a freeze function. Create and use a freeze/unfreeze macro.

Set Automation Mode

Click on Read or Write button.

Right-click on Env button, choose one of Trim/Read, Read, Write, Latch or Touch.

Add FX to Track

Right click over track FX bin.

Click on FX button.

Save Track(s) as Track Template

Right-click, then Save as Track Template.

Select track(s), right-click, then Save Tracks as Track Template.

Group Parameters

Right click over parameter, then select a group or
choose Group Manager.

Right click and choose Group Parameters (or use Group Matrix View).

Hide/Show Track

Right click and choose Hide Track, or Press M to
display track manager

Right click and deselect Show track in track list, or Right-click, Filter Visibility by Track Name,
orView - SWS Tracklist (requires installation of SWS Extension Pack).

Archive Track

Use track's Archive button.

REAPER does not support this feature. However, by default tracks that are muted and
hidden will use no resources.

10
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Task/Activity In SONAR you did this ... In REAPER you do this ...
Change Track Order Drag and drop - be careful! Drag and drop (on track number) — be careful!
Use Mixer View Views - Console. Use buttons on left to View - Mixer. Use right click menu (over background area) to customize.
customize.
Create a Send to a Bus Create the bus, then right-click in track panel, Create an empty track to be used as a bus, then .... Drag and drop from the track I/O
Insert Send then choose bus. button to the bus I/O button, or Click on the track I/O button and add send, or Use the
Routing Matrix View.
Create a Send to Another Track SONAR does not support this feature. Drag and drop from the source track I/0 button to the destination track I/O button, or
Click on the track I/O button and add send, or Use the Routing Matrix View.
Create Submixes Create a bus. In the track panel for each track to | Create a track to be used as submix and create sends from each track to be included.
be included in the submix, select the bus from the |Disable direct output to Master for each of these tracks, or Insert a new empty track above
output drop down list. the first track in the group. Click on its track folder icon once to make it a folder. Click twice

on the track folder icon for the last track in the group.

Lock Track Controls (toggle) SONAR does not support this feature. Right click over track number, choose Lock Track Controls.
Show Bus/Track Peak Markers Use Meter Options drop-down list on toolbar. REAPER does not support this feature.
Bus Waveform Preview (toggle) Use the bus Waveform Preview button. REAPER does not support this feature.

Mouse and Keyboard Shortcuts, Tips and Techniques:
REAPER has numerous shortcuts and actions that can be used to control track display and visibility. Listed here are those most commonly used:

Track Display and Navigation Shortcuts

Drag between tracks with mouse Adjust individual track height W or Home Go to start of project

PageUp Increase all track heights (zoom in vertical) End Go to end of project

PageDown Decrease all track heights (zoom out vertical) Ctrl + Alt + Up Go to previous track

* key Toggle all tracks normal/minimized Ctrl + Alt + Down Go to next track

~ key Toggle maximize track Toggle View = Mixer Ctrl + M

Double-click vertical scroll bar Toggle minimize/normal/maximize Ctrl + At + M Show/Hide Master in Arrange View
+ Zoom out horizontal Mousewheel Zoom in/out horizontal

- Zoom out horizontal Ctrl + Mousewheel Zoom in/out vertical

Ctrl + PageDown Zoom to project length

11
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5. Media Item Management Basics

Section Overview

REAPER and SONAR superficially have quite similar approaches to managing and editing media items: however, the deeper you dig, the greater the differences. The information on this
page should at least get you started. Some points to note:

¢ Fade-ins, fade-outs and slip edits are handled similarly by both programs.
¢ Basic techniques for copying, moving and deleting items are quite similar. REAPER also has many nudge options, including a Nudge window (right-click, Nudge Items).

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Insert Media Item

File » Import or use Loop Explorer.

Insert » Media File or use Media Explorer (View » Media Explorer).

Modify Clip/Item Properties

Right click, choose Clip Properties.

Right-click, choose Item Properties (or press F2). Many of the options available are
equivalent.

Display Media Item Icons

FX button will be displayed if FX have been
added to the media item.

Other icons used include mute clip and lock
clip.

Options - Preferences, then Appearance, Media. Enable/disable as you wish.

ki edia itermn icons
Locked kuted F Motes Froperties
Unlocked Unrnuted Mo B Mo notes || Resampled anly

Grouped

Open MIDI Item with MIDI Editor
(Piano Roll View)

Double-click on item.

Double-click on item. At a glance, the two MIDI Editors appear quite similar, but there are
many fundamental differences. For example, SONAR makes extensive use of tools, REAPER of
actions.

Open MIDI Item with In-Line Editor

Click PRV button in track pane.

Select item, right-click, Open Items in Editor - Open in In-Line Editor.

Open Audio Items with External Audio
Editor

Tools - Select Editing program from menu.

Right-click on item, then Open Items in Editor - Open Items with editor as specified in
Options - Preferences then External Editors.

Snap to Grid (settings and enable)

Use Snap to Grid button/combo on toolbar.

Options = Show Grid Settings, or use Grid button on main toolbar.

Ripple Editing

SONAR does not support this feature.

Options - Ripple Editing (toggles one track, all tracks, off)

Add FX to Media Item

Right-click, Insert Effect

Click on item FX button, or Right-click, Take -» Show FX Chain for Active Take, or Shift + E

Toggle Display of Takes in Lanes

Use track's Track Layers Button or Tracks -
Layers -» Show Layers

Options = Show All Takes in Lanes or Ctrl+ L

12




Task/Activity

In SONAR you did this ...

From SONAR to REAPER

In REAPER you do this ...

Use Navigator View

Views - Navigator.

View - Navigator.

Adjust Take Volume

Closest equivalent is the track Trim Fader.

of item to increase.

Click and drag down from top edge of of item to lower: Shift click and drag up from top edge

Show Media Item Envelopes

Right-click, Envelopes - Create Clip Envelope

Right click, Take, then Take Volume Envelope, or Take Pan Envelope, or Take Mute Envelope.

Split Media Item

Select item, position cursor, press S

Select item, position cursor, press S.

Create Loop From Item

Right-click, Clip Properties, then Audio
Stretching, then Enable Looping

Item Settings -» Loop Item Source.

By default REAPER's media items are loop enabled. To toggle this status off/on, right click,

Mute Part of Media Item

Use Mute tool.

Create a custom action to split and mute, or use track or take Mute envelope.

Mute Media Item (toggle)

Right-click, More - Clip Mute/Unmute

Right-click, Item Settings » Mute or use item mute button.

Lock Media Item (toggle)

Right-click, More - Clip Lock/Unlock

Right-click, Item Settings - Lock Item or use item lock button.

Render Item

Right-click, Bounce to Clip

Right-click then select one of the Apply Track FX or Render Items options.

Group Media Items

Select media items, right-click, then Create
Selection Group from Clips.

Select items, right click Group » Group Items.

Manage Grouped Media Items Status

SONAR has no real equivalent.

Select items, right click Group, then choose from menu.

Nudge Items

Process - Nudge from main menu, or use
keyboard shortcuts.

dialog box.

Use keyboard shortcuts (see below), or right-click then choose Nudge Items

... for Nudge

Keyboard Shortcuts, Tips and Techniques:

View/Edit Item Properties
View Source Media Properties
Cut Selected Area of Item
Copy Selected Area of Items

Copy Loop of Selected Area of Items

Time stretch (warp) item
Show FX Chain for Active Take

F2

Ctrl + F2

Ctrl + Delete

Ctrl + Shift + C

Ctrl + Alt+ L

Alt click and drag from start or end
Shift + E

Split Item(s) at Cursor

Split Item(s) at Time Selection
Nudge item(s) up/left/right/down
Nudge contents of item left/right
Grow/Shrink left edge of item
Grow/Shrink right edge of item

Move cursor to left/right edge of item

13
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Shift + S

Num Lock 2/4/6/8
Num Lock 1/3

Ctrl + Num Lock 4/6
Alt + Nim Lock 6/4
Ctrl + [/ Ctrl + ]
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6. Managing and Editing MIDI Items

The way in which MIDI items are managed and edited in REAPER is very significantly different from SONAR. This really is an area where you may need to take some time to adjust to the
differences. The following table contains some useful pointers.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Create MIDI Items

Record, or use Piano Roll View.

Record, or select track and make time selection, then Insert - New MIDI Item. Double-
click on this to open MIDI Editor.

Loop Enable MIDI Item

Clip Properties » Enable Looping

By default, all media items (including MIDI) are loop enabled. This can be changed for
individual items (or selections of items) using the Item Settings - Loop Item Source toggle
command from the right-click context menu.

To change the default behavior for new items, disable Loop source for new MIDI items in
Project » Defaults.

Assign MIDI Items to a Synth.

Use a separate audio track or instrument track.

Insert Synth in track FX chain.

Assign Different Channels from the
Same MIDI Item to Different Synths.

SONAR does not support this feature.

Use a separate send (track i/o button) for each channel that requires a separate
instrument.

Edit MIDI Items or Clips

Use in-line Piano Roll, standard Piano Roll, or
Event List View.

Double click to open in standard MIDI Editor or right-click and choose Open Items in Editor
- Open Items in Inline Editor. Use View - Mode: event list in the standard MIDI editor
for CCs and other events.

Manage Items in Sequence on a Single
Track

All MIDI notes on the same track are essentially
treated as a single clip (item). For example, all
are accessible when you open the Piano Roll or
Event List View. You may also Bounce to Clip to
join a selection of shorter items.

Each item is separate and can be opened in its own MIDI Editor Window. By default, the
dimensions of that MIDI Editor window will be constrained by the dimensions of the MIDI
item. This issue simply does not arise in SONAR. If in REAPER you think you are likely to
need to add notes (or other events) before an item, after an item, or between existing
items then it would be wise to prepare for this before opening the MIDI Editor.

To do this, you should disable the Loop Item Source option (right-click, then Item Settings,
then disable the Loop Item Source toggle option), then stretch its edges outwards (slip edit
style), or Join the items together, by selecting them, then right clicking and choose Glue
Items from the context menu. See screen shots below table. This enables you to open
them all together in the MIDI Editor and add notes in between the original items.

You can also drag the edge of a loop disabled item in the MIDI Editor in order to extend it.
Also, if within the MIDI Editor you insert a note that goes beyond the end of the item then
that item will automatically be extended.
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Task/Activity

In SONAR you did this ...

From SONAR to REAPER

In REAPER you do this ...

Read Cakewalk .ins Instrument

Definition File for Bank/Patch Names.

Options - Instruments, then click on Define,
then Import. Select file, click on Open.

Right-click on track name or nhumber and choose Show Track MIDI Controls. This opens
ReaControl MIDI in the track FX chain. Display this, click on Load File, select file, then click
on Open.

ReaControl MIDI can also be used with individual MIDI items, via their FX chains.

Use Various MIDI Track Controls

Use widgets in track control panel.

Use the various ReaControl MIDI controls. Also, many JS MIDI plug-ins are available. Type
“MIDI” in the FX Filter for a list.

Handling System Exclusive Data

Use Sysx View.

Drag and drop a .syx file directly on to the track to load directly into a track, or Use
ReaControl MIDI: click on Sysex Edit button and paste data in. FO and F7 are added
automatically at the start and end respectively.

Export MIDI Data as MIDI File

File » Save As. For individual clips, Export->
MIDI Groove Clip

File » Export Project MIDI. For individual items, open in MIDI editor, then File- Export to
new MIDI File.

Add Lyrics to Project

Views = Lyrics.

REAPER has no lyrics view, but has rudimentary lyrics handling via text import. In the
MIDI editor, choose Import Lyrics for Selected Notes from File from the Action list. Lyrics
and other text can also be displayed directly on the item: Right-click, then Item Settings -
Item Notes. You can then use the Load button to import a file, or paste text in.

Joining MIDI Items in REAPER

3 FKevboard

EEE®E evbosrd untitle

Before ... two separate discrete MIDI

BEDE@Kevboud ..
: items on a track.

Kepboard

After selecting both items and choosing
Glue Items from the context menu.
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From SONAR to REAPER

7. Plug-in and FX Management

Section Overview

Most SONAR users who come to REAPER find that at first they miss being able to manage a track's plug-ins directly from a bin in the track control panel (although these can be accessed
directly in the Mixer view). However, you will soon discover that REAPER's FX Window includes an impressive selection of other features which should more than make up for this.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Add FX to a Track

Right-click over FX bin, then follow menu.

Click Add button on track FX window. Double-click on required FX or drag and drop.

Change Order of Track FX

Drag and drop.

Drag and drop.

Delete FX from Track

Select FX, press Delete.

Select FX, press Delete.

Bypass FX (toggle)

Use FX Bypass toggle in track FX bin.

Use FX Bypass toggle in track FX Chain window or FX window.

Rename and Reorganize Plugins

Tools » Cakewalk Plug-In Manager.

View - FX Browser.

Create FX Chain

SONAR does not support this feature.

Right-click on track FX chain then Save FX Chain or Save Selected FX as Chain.

Create Track Default FX Chain

SONAR does not support this feature.

Right-click on track FX chain then Save Chain as Default for New Tracks.

Add FX Chain to a Track

SONAR does not support this feature.

In FX Chain Window choose FX - Add FX Chain from top menu.

Rename Individual FX Instance

SONAR does not support this feature.

Select the FX, then press F2 or right-click, then Rename FX Instance.

Adjust FX Wet/Dry Mix

SONAR does not support this feature.

Use Wet/Dry rotary control next to bypass checkbox in FX window.

Use in Track Parallel FX Processing

SONAR does not support this feature.

Click on pin connector (labeled 4 in 2 out or similar) to assign FX inputs and outputs to
specific channels. Use a JS mixer plug-in to mix different parallel FX streams.

Add Parameter Controls to Track
Control Panel and Mixer Control Panel

Up to four controls per track can be displayed
at any one time in Console View only.

Touch parameter control with mouse, then click on Param button in FX chain window.
Choose Show in Track Controls.

Show per Track EQ in Mixer View.

Use EQ Plot and EQ toggle buttons in Console
View.

Need to be added individually to each track (or use FX chains or track templates).

Manage Plug-in Preferences/Settings

Options = Global -» VST Plug-ins

Options - Preferences then Plug-ins, VST, and ReWire/DX pages.
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8. Automation

Section Overview

From SONAR to REAPER

Both SONAR and REAPER use envelopes to automate track and FX parameter data, but their respective feature sets are significantly different. This table should help steer you thru these.
Probably the most significant difference between the two is that SONAR does not support Parameter Modulation.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Create Track Control or Send Envelope

Right-click on media item, Envelopes - Create
Track Envelope then choose from menu.

Click on track Env button to display envelopes window for track, then check boxes for
envelopes required, or use keyboard shortcuts (V for Volume, P for Pan).

Create Track FX Parameter Envelope

Right-click on media item, Envelopes - Create
Track Envelope then select FX, then select
parameter.

Click on track Env button to display envelopes window for track, then check boxes for FX
parameter for envelopes required, or In FX window, touch parameter with mouse then click
on Param button, then Show Track Envelope.

Create Media Item Control Envelope

Right-click on media item, Envelopes - Create
Clip Envelope then select parameter..

Right-click on media item, then Take, then select Volume, Mute or Pan envelope from
submenu.

Create Item FX Parameter Envelope

Right-click media item, Envelopes -+ Create
Clip Envelope then select FX and parameter.

REAPER does not support this feature.

Setting Automation Mode

Use Track Controls — Read or Write only.

Right-click on Env button, select one of Trim/Read, Read, Write, Touch, or Latch.

Global Automation Override

SONAR does not support this feature.

Right-click Global Automation Override button on Transport Bar.

Add/Manage Envelope Points

Use mouse.

Options - Preferences - Editing Behavior - Envelopes sets mouse behavior (click, shift-
click, double-click, etc.) for adding, editing and resetting points, adjusting segments, etc.

Curve Shape and Other Options

Right-click on envelope.

Right-click on envelope.

Show Envelope in Separate Lane

SONAR does not support this feature.

Right-click on envelope, choose Show Envelope in Lane (toggle).

Draw Envelope Curves with Mouse

Select Envelope Draw tool, click and drag.

Depending on preferences, Ctrl-click and drag.

Envelope Bypass Mode (toggle).

Right-click envelope, then Automation Read
Disable.

Right-click on envelope, then Bypass Envelope.

Parameter Modulation

SONAR does not support this feature.

Parameter Modulation is a very big topic. To cover it in detail would go beyond the scope of
this document. In short,it lets you use any audio stream or FX parameter from any track to
control the behavior of any FX parameter on itself or any other track.
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From SONAR to REAPER

9. Loops, Markers and Regions

Section Overview

Both SONAR and REAPER use loops and markers to help you manage your projects. With the addition of the SWS Extensions, REAPER offers you several extra features. The information in
this table assumes that the SWS Extensions have been installed. REAPER also uses regions, something that SONAR does not recognize.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Create Loop Selection

Click and drag along timeline, then Loop »
Set Loop Points.

Click and drag along timeline.

Create Time Selection

Click and drag along timeline.

Click and drag in background area in Arrange View.

Link Loop Points to Time Selection

SONAR does not use this concept.

Options - Loop Points Linked to Time Selection (toggle).

Create Marker

Insert - Marker or (on the fly) press F11

Insert » Marker or (on the fly) press M or Shift+M.

Display Marker View

Views - Markers

View - SWS MarkerList.

Reorder/Renumber Markers

SONAR does this automatically.

Right-click in MarkerList window, Reorder Marker IDs

Go to Marker

Use Transport Bar or Markers window.

Type number or use MarkerList window.

Delete Marker

Select in Markers window, press Delete.

Alt click on marker in timeline, or right-click and choose Remove Marker.

Create Smart (Command) Markers

SONAR does not support this feature.

Begin marker name with ! Followed by command ID or IDs.

Create Marker Sets and Sub-Sets

SONAR does not support this feature.

Right-click in MarkerList window, Save Marker Set.

Recall Marker Set or Sub-Set

SONAR does not support this feature.

Right-click in MarkerList window, choose Load Markername.

Copy Markers to Another Project

SONAR does not support this feature.

Right-click in MarkerList window, Copy Marker Set to Clipboard. Open other project in new
project tab, then right-click in MarkerList window, Paste Marker Set from Clipboard.

Create a Region

SONAR does not support this feature.

Define time selection, then either right-click on timeline, Create Region from Selection or
press Shift+R.

Move Region

SONAR does not support this feature.

Click and drag along timeline.

Copy Region

SONAR does not support this feature.

Ctrl click and drag along timeline.
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From SONAR to REAPER

10.Project Rendering and Related Topics

Section Overview

With both SONAR and REAPER you can mix down and render your projects for export, for example, as internet ready MP3 or CD ready WAV files, or for export to other programs. The
topics listed here fall loosely into this category. There are some interesting differences between the two feature sets.

Task/Activity In SONAR you did this ... In REAPER you do this ...
Export as OMF File File » Export » OMF REAPER does not support this feature.
Export as EDL or EDL Text File SONAR does not support this feature. File » Save As, then select file type.
Export Mix as Stereo MP3 File File » Export - Audio. File » Render. Select Stereo from Channels drop down list and MP3 as output format.

SONAR also includes Pyro Web Publisher. Select Render Master Mix.

Export Mix as Stereo 16 bit WAV File (for | File » Export » Audio. File » Render. Select Stereo from Channels drop down list and WAV as output format.
audio CD) SONAR also includes Pyro CD Burner. Select Render Master Mix. Select Bit Depth 16, Sample rate 44100.

Export Individual Tracks as Separate Various options and permutations available Include with your settings and specifications Render Stems (Selected Tracks).

Files from Source Category drop-down list.

Export in Multichannel Format Requires Multichannel Format to have been | Along with your other settings, select the required number of Channels and if required

specified in Surround tab of Project Options. |enable the option Render Multichannel Tracks to Multichannel Files.
Choose Multichannel from Channel Format
drop-down list.

Import Audio from CD File » Import - Audio CD. Use the Media Explorer View. Drag and drop to arrange view.

Export Mix to Audio CD After preparing projects to required format, | After preparing project to required format, File » Render. Amongst other options, select
Tools - Burn Audio CD. Output Format Audio CD Image. See User Guide for details.

Batch Render Files SONAR does not support this feature. Prepare individual files in File » Render dialog box, clicking each time on Queue Render.

Then File » Show Render Queue, with Render All or Render Selected.

19



From SONAR to REAPER

11.Customization

Section Overview

Understanding REAPER's customization lies at the very heart of really getting to grips with the program. Now read on ..

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Create Custom Actions

Some ability to bind keys to commands thru
Options = Key Bindings. Cannot create
custom actions or macros.

Use Actions - Show Actions List to access actions editor. Any command can be assigned a
keyboard shortcut. Many hundreds of additional actions that can be assigned to keyboard
shortcuts, menus, toolbars, or control devices.

Any number of actions can be chained together to create custom macros, also assignable
to keyboard shortcuts, menus, toolbars, or control devices.

Custom Menus

Use Options » Menu Editor to rearrange
SONAR menus, including hiding unwanted
commands.

Custom Toolbars

Right-click on any displayed toolbar and
choose Customize. Finite range of custom
tools is available.

Use Options -» Customize Menus/Toolbars to customize menus and/or toolbars.
You can rearrange REAPER's menus, including hiding unwanted commands.

You can also add REAPER actions and your own custom actions to REAPER menus and
toolbars.

Custom Colors and Skins

SONAR supports custom color schemes but is
not skinnable.

Use Options - Preferences then Appearance, Theme Editor to modify or create your own
color schemes.

You can also create and import your own skins.
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From SONAR to REAPER

12.Miscellaneous: What Else Is Similar, What's Different and What's Missing?

Section Overview

This section summarizes in overview those areas where SONAR and REAPER are most significantly different. Also included here are some features that are present in one or other of these

DAWSs but not the other.

Task/Activity

In SONAR you did this ...

In REAPER you do this ...

Assign Parameter Controls to Control
Surface

Use ACT.

REAPER handles this very differently, via Param button in FX window and Actions list editor.

Create/Use Audio/MIDI Matrix

Use Matrix View.

REAPER does not have a Matrix view.

Edit Notation or Lyrics

Use Staff View or Lyrics View.

REAPER does not include a Staff View or Lyrics view, but you can use an external MIDI Editor
for this.

Stretch and fit items to tempo, etc.

Use Audio Snap.

The closest equivalent to this in REAPER is Dynamic Splitting: right-click on media item, then
Item Processing = Dynamic Split Items.

Automatically correct vocal pitch

Use V-Vocal.

The closest equivalent in REAPER is the Cockos VST plug-in ReaTune.

Surround panning

Use the Surround Panner.

REAPER does not have a surround panner. You can mix for surround sound in REAPER, but if
you wish to do so it is advisable to use a third party VST plug-in.

Automatically color tracks according
to the label

SONAR does not support this feature.

View - SWS Auto Color (requires SWS extensions).

Create and manage mixer snapshots

SONAR does not support this feature.

View - SWS Snapshots (requires SWS extensions). Snapshots allow many different mixer, track,
FX, etc. settings (and different permutations of these) to be saved and recalled within a single
project file, and even to be copied between project files.

Create and manage screen sets

Use Views - Layouts window to create and
manage layouts.

View = Screen Sets. Screen sets allow different windows and track layouts to be saved and
instantly recalled.

Monitor and manage CPU, disk and
RAM performance

SONAR displays only minimal information on
its CPU and Disk meters.

View - Performance Meter for comprehensive performance management. Double-click on any
track name in the Performance Meter Window to open FX window for that track.
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